Hilfe mit Excel - Auch ein Rätsel ? Excel 2013 - Problems splitting cell containing two decimal num

Dieses Thema im Forum "Rätselecke" wurde erstellt von Altaya, 14. August 2014.

  1. Altaya
    Offline

    Altaya BdW-Veteran

    Registriert seit:
    11. Januar 2009
    Beiträge:
    2.637
    Hi Ihr!

    Vielleicht kann auchhier jemand helfen, fiel mir erst ein, nachdem ich schon auf Superuser gepostet hatte. Werde noch irr mit dem blöden Office. Aber die Frage kommt von einer Kollegin und im Büro haben wir halt nur Office ...

    Excel 2013 - Problems splitting cell containing two decimal numbers



    I need to separate values that look like this and are in one column in an excel spreadsheet.

    48.116667, 11.55

    I though this would be easy and did this: Select the column, click on (Data Ribbon) - Text to columns

    next I choose "delimited", in the next window I choose "comma" as the delimiter and in the preview everything looks fine. I see 2 columns with these numbers

    48.116667 and in the next column 11.55

    I click next and in the Data Preview I see that both columns that are to be created have the "General" Format.

    Still the output looks correct and like in the previous window.

    I click "Finish" and get this
    [​IMG]

    in the formula bar it says for my left number: 48116667

    In the table it shows in the left column: 48.116.667 (centered right)(number format) And it says in the right column (correctly): 11.5 (General) (centered left)

    The left number now a 8 digit number without any separators in the data entry field above and with 2 dots in the table itself. The second number is shown correctly.

    I need both numbers to look just like the right number and without any error sign next to the field. Just a "normal" number field with comma OR Point (doesn´t matter which) as my decimal sign and no additional points or signs in any number.

    What I have tried:

    In Options-Advanced I deselected "Automatically add decimal point".

    This might also be relevant: In the Options-Advanced it also says Use system separators (which is active) and there: comma for Decimal separator and Point for Thousand Separator

    It might also be relevant that I use Windows 7 German Edition as my Operating System.

    Would be great if could help, thanks in advance!

    Anhänge:

     
  2. Deckard
    Offline

    Deckard BdW-Gildenleiter

    Registriert seit:
    31. August 2007
    Beiträge:
    6.103
    Ich hab das Problem auf Englisch nicht verstanden! :)

    Falls du bie heute Abend keine Antwort hast, komm mal gegen 20 Uhr im TS vorbei.
     
  3. Altaya
    Offline

    Altaya BdW-Veteran

    Registriert seit:
    11. Januar 2009
    Beiträge:
    2.637
    Ok, mach ich :)
     
  4. Cohain
    Offline

    Cohain BdW-Community

    Registriert seit:
    27. Januar 2002
    Beiträge:
    1.690
    Ich habe vielleicht eine Lösung, nutze aber Office 2010. In Schritt 3 von "Text to columns" gibt es den Punkt "Advanced/weitere". Dort bei 1000er Trennzeichen ein Leerzeichen reinmachen. Das sollte so aussehen:
    upload_2014-8-14_13-10-38.png

    Das Komma bei Dezimaltrennzeichen so belassen. Bei mir hat es in office 2010 so funktioniert das es dann so aussieht:
    upload_2014-8-14_13-18-1.png

    Wichtig dabei ist das bei 1000er Trennzeichen das Leerzeichen aus dem Menü Ausgewählt wird, es reicht nicht einfach den Punkt der dort drin steht zu löschen.
    Zuletzt bearbeitet: 14. August 2014
     
  5. Altaya
    Offline

    Altaya BdW-Veteran

    Registriert seit:
    11. Januar 2009
    Beiträge:
    2.637
    Ok, dann siehts bei mir wie folgt aus:
    upload_2014-8-14_19-55-53.png
    Sieht schon ganz gut aus, nur die Error-Meldungen noch.
    Beide Zellen sind jetzt aber immerhin schon mal General Format. Oder scheinen sie das nur zu sein?

    Ich will die Error-Meldungen auch weg kriegen.

    Wenn ich jetzt aber auf die ErrorMeldung klicke und mache "convert to number" , dann wird wieder ne Ellenlange Zahl aus dem linken:
    upload_2014-8-14_19-59-51.png

    Und beim rechten Error-Fenster kann ich gar nicht "Convert to number" machen:

    upload_2014-8-14_20-0-50.png

    Waaaaaaah
     
  6. Cohain
    Offline

    Cohain BdW-Community

    Registriert seit:
    27. Januar 2002
    Beiträge:
    1.690
    Da bin ich nun überfragt da Excel 2010 keinen Fehler anzeigt (siehe Bild) und ich es deshalb leider nicht nachvollziehen kann.
     
  7. Kitara
    Offline

    Kitara BdW-Administrator

    Registriert seit:
    7. Dezember 2001
    Beiträge:
    8.484
    Was ist denn das für eine Zahl? Eine mit einem englischen . als Trennzeichen und im deutschen Format wäre das eigentlich 48,116667? Vielleicht müsstest du deinem Excel noch sagen, dass es den . als Dezimalzeichen ansehen soll und nicht ein , oder nach der Trennung in der Spalte durch suchen und ersetzen alle "." durch "," ersetzen falls das geht.
     
  8. Cohain
    Offline

    Cohain BdW-Community

    Registriert seit:
    27. Januar 2002
    Beiträge:
    1.690
    Wenn man das Dezimalzeichen zum Punkt ändert, machte Excel nicht das was es sollte. Ich glaube aus 48.116667 wurde 48116667.
     
  9. Eyvindur
    Offline

    Eyvindur BdW-Veteran

    Registriert seit:
    15. Juni 2008
    Beiträge:
    1.536
    soweit ich das am Handy sehen und verstehen kann ist ist das nen klassisxhes excel Problem bei internationalen Formaten. US/En haben zur dezimaldarstellung der nachkomma Zeichen einen"." wogingegen das Komma gerne auch als tausender Zeichen genommen. Ohne die wirkliche aufgabenstellung zu kennen ist es hier im kern ein excel problem. Lässt sich manuell beheben indem man . Zu , macht und umgekehrt. Wenn es um grosse bis sehr grosse datenmengen geht helfen aktuelle editoren wie notepad++ um hier massenersetzungen durchzuführen. Wenn die Daten an der Quelle bereits so ausgepuckt werden würde ich da nochmal prüfen inwieweit internationle Einstellungen beim export genutzt wrden können.
     
  10. Altaya
    Offline

    Altaya BdW-Veteran

    Registriert seit:
    11. Januar 2009
    Beiträge:
    2.637
    2 LÖSUNGEN

    a)
    @Xerxio hat es mit einer Formel gelöst, und die Zahl als String behandelt und auseinandergenommen und wieder zusammengesetzt. Als Anhang gezippt hier dran, wenn jemand basteln will.

    Das war ein wirkliches Rätsel/Puzzle, im Anhang. In der Datei hatte ich für das linke Ergebnis-Feld schon alles so zusammengebaut, dass nur noch auf A9 verwiesen wurde. Rechts hatte ich noch nicht gemacht, dann die andere Lösung gefunden.

    DANKE für neue Erkenntnisse zu Excel, @Xerxio


    b)
    Auf superuser.com wurde empfohlen mit den Options-Advanced „Use system operators“ rumzuspielen, weil es wohl was mit dem DE Operating System zu tun hat.



    Habe dann folgende Settings benutzt und es ging mit obiger Methode einwandfrei. Einfach die „Use System Operators“ abgewählt.
    upload_2014-8-15_20-35-22.png
    Decimal Separator „.“ EGAL, da abgewählt.
    Thousands Separator „Spacebar“ (!) EGAL, da abgewählt.
    Insgesamt „Use system separators“


    Dann geht es:

    Ausgangsbild:
    upload_2014-8-15_20-34-57.png

    „umwandeln“ mittels „Text to columns“ mit folgenden Einstellungen
    upload_2014-8-15_20-33-17.png


    Hierbei ist wichtig, dass sich diese Advanced Settings auf die zu konvertierenden Daten beziehen, daher muss ich hier bei Decimal Sep. den Punkt eingeben und bei Tausender-Trennung habe ich einfach Leerzeichen genommen, da davon ja keine innerhalb der Zahlen sind.


    das hier raus:
    upload_2014-8-15_20-32-55.png

    Beide richtig angezeigt, in Zellen mit „General“ Format und ohne Error-Meldung

    Uff :)

    Anhänge:

    Zuletzt bearbeitet: 15. August 2014